Skip to content

Structural Element Properties

Class full path: NemAll_Python_ArchElements.StructuralElementProperties

Bases: ArchBaseProperties

Functions

AddHole(holeGeometry)

Adds a hole to the list of holes for the Structural Element

Parameters:

Name Type Description Default
holeGeometry BRep3D
  • 3D BRep Geometry of the hole
required

Returns:

Type Description
int

Unique ID for the created hole

GetAnglesAtEnd()

Returns angles in X, Y direction for the end of the Structural Element, as tuple(X, Y)

GetAnglesAtStart()

Returns angles in X, Y direction for the start of the Structural Element, as tuple(X, Y)

GetBodyAxis()

Get Body Axis

Returns:

Type Description
Line3D

Axis as Line3D

GetCenterAxis()

Get Center Axis as a Allplan::Geometry::Line3D

Returns:

Name Type Description
Allplan Line3D

:Geometry::Line3D which contains information about start and end point coordinates

GetDoubleProfileGap()

Gets double profile gap ProfileCatalogService calls

GetEndPointAdditionalOffset()

Get the end point distance dx/dy

Returns:

Type Description
Vector3D

Position as Vector3D

GetEndPointZOffset()

Get the value of Z offset of the anchor point at end the point of SF element

Returns:

Type Description
float

double

GetEndReferencePointType()

Get type the reference point at end

Returns:

Type Description
CustomBoxPoint

CustomBoxPoint

GetHeightProperties()

Get HeightProperties

GetHoles()

Returns existing holes as python dictionary, where key is hole ID, value is its geometry

GetProfileAngle()

Get rotation angle of element profile.

GetProfileShapeProperties()

Get ProfileShapeProperties

GetShapeTypeAtEnd()

Returns truncation type at the end of the Structural Element

GetShapeTypeAtStart()

Returns truncation type at the start of the Structural Element

GetSkeletonSolidElementProperties()

Get SkeletonSolidElementProperties

GetStartPointAdditionalOffset()

Get the start point distance dx/dy

Returns:

Type Description
Vector3D

Position as Vector3D

GetStartPointZOffset()

Get the value of Z offset of the anchor point at start the point of SF element

Returns:

Type Description
float

double

GetStartReferencePointType()

Get type of the reference point at start

Returns:

Type Description
CustomBoxPoint

CustomBoxPoint

GetZCoordsVisibility()

Get visibility of Z coordinates of insertion point

HasTwoAnchorPoints()

Get the check box value if element have two anchor points

Returns:

Type Description
bool

True/False

RemoveHole(holeID)

Removes a hole to the list of holes for the Structural Element

Parameters:

Name Type Description Default
holeID int

: ID of the hole to remove. This ID is obtained by AddHole operation

required

SetAnglesAtEnd(angleX, angleY)

Sets angles in X, Y direction for the end of the Structural Element

SetAnglesAtStart(angleX, angleY)

Sets angles in X, Y direction for the start of the Structural Element

SetAttribute(attrib)

Set the attribute

Parameters:

Name Type Description Default
attrib object

Attribute

required

SetCommonProperties(comProp)

Set the Common properties

Parameters:

Name Type Description Default
comProp CommonProperties

Common properties

required

SetDoubleProfileGap(desiredGap)

Set the gap of double profile. Returns: true if attribute Gap was correctly set and exists / false if given profile doesn't have attribute Gap.

SetEndPointZOffset(desiredOffset)

Set the value of the Z offset of the anchor point at the end point of SF element to desired value.

SetProfileAngle(value)

Set the rotation angle of element profile

Parameters:

Name Type Description Default
value Angle

rotation angle

required

SetProfileShapeProperties(value)

Set the Column ProfileShape Properties

Parameters:

Name Type Description Default
val

ProfileShape Properties of Column

required

SetShapeTypeAtEnd(endTruncationType)

Set truncation type at the end of the Structural Element

SetShapeTypeAtStart(startTruncationType)

Set truncation type at the start of the Structural Element

SetStartPointZOffset(desiredOffset)

Set the value of the Z offset of the anchor point at the start point of SF element to desired value.

SetTwoAnchorPoints(areTwoAnchorPoint)

Set the value if element have two anchor points

__init__ overload

__init__()

Initialize

__init__(structuralElementProperties)

Copy constructor

Parameters:

Name Type Description Default
structuralColumnProps

Structural Element properties

required