Skip to content

Anchorage Type

Class full path: NemAll_Python_Reinforcement.AnchorageType

Bases: IntEnum

Types of the anchorage

Attributes

eAnchorageHook = 2 class-attribute instance-attribute

eAnchorageHookOneCrossBar = 4 class-attribute instance-attribute

eAnchorageStraight = 1 class-attribute instance-attribute

eAnchorageStraightOneCrossBar = 3 class-attribute instance-attribute

eAnchorageStraightTwoCrossBars = 5 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
AnchorageType

value for the key