Skip to content

Undo Redo Service

Class full path: NemAll_Python_IFW_Input.UndoRedoService

Implementation of the undo/redo service

Functions

ActivateCollectedElementsForFinishUpdate()

activate collected elements from undo step, important for next finish update

CollectElementsForMultipleTransactions()

Collect the elements for adding multiple transactions to one undo step

CreateUndoStep overload

CreateUndoStep(eventID)

Create an undo step

Parameters:

Name Type Description Default
eventID int

Event ID of the undo step

required
CreateUndoStep()

Create an undo step

IsInUndoService() staticmethod

Check if an active undo service is present

Returns:

Type Description
bool

Active undo service is present

SetUndoDescription(textID)

Set the undo step description independent from menu event text

Parameters:

Name Type Description Default
textID int

Text ID of the undo step

required

SetUndoStepEvent(eventID)

Set the undo step event

Parameters:

Name Type Description Default
eventID int

Event ID of the undo step

required

__init__ overload

__init__(doc, isPassivateAll=False, isLockPreviewDraw=False, collectEleForMultipleTransactions=False)

Constructor

Parameters:

Name Type Description Default
doc DocumentAdapter

Current document

required
isPassivateAll bool

if true -> call esapas_2(), default is false

False
isLockPreviewDraw bool

Lock the preview drawing during the undo step creation

False
collectEleForMultipleTransactions bool

Collect the elements, if the UndoRedoService is included in multiple transactions

False
__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element UndoRedoService

Element to copy

required