Skip to content

Symbol3D Properties

Class full path: NemAll_Python_BasisElements.Symbol3DProperties

Symbol3DProperties class

Attributes

ControlPointOffset: None property

Property for control point offset

:type: None

DescriptionText: None property

Property for description text

:type: None

Height: None property

Property for height

:type: None

IsScaleDependent: None property

Property for scale dependency

:type: None

IsStation: None property

Property for station

:type: None

PrimaryPointNumber: None property

Property for primary point number

:type: None

RotationAngle: None property

Property for rotation angle

:type: None

SecondaryPointNumber: None property

Property for secondary point number

:type: None

StationCode: None property

Property for station code

:type: None

SymbolID: None property

Property for symbol ID

:type: None

Width: None property

Property for width

:type: None

Functions

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop Symbol3DProperties

Symbol3DProperties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__()

Initialize

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string