Skip to content

e Track Line Type

Class full path: NemAll_Python_IFW_Input.eTrackLineType

Bases: IntEnum

Definition of the track line types

TRACKLINE_NO : No track line TRACKLINE_ENDLESS : Endless track line TRACKLINE_EXTENSION : Extension track line from the start point TRACKLINE_EXTENSION_END: Extension track line from the end point

Attributes

TRACKLINE_ENDLESS = 1 class-attribute instance-attribute

TRACKLINE_EXTENSION = 2 class-attribute instance-attribute

TRACKLINE_EXTENSION_END = 3 class-attribute instance-attribute

TRACKLINE_NO = 0 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
eTrackLineType

value for the key