Skip to content

Handle Properties

Class full path: HandleProperties.HandleProperties

Implementation of the handle properties class

Attributes

abs_value: bool property

Get the absolute value state of the properties

angle_placement: Optional[AllplanGeo.AxisPlacement3D] property writable

Get the placement for the 3D angle input

build_ele_index_list: List[int] property writable

Get the index list of the building elements

click_state: bool property

Get the click state:

- False: Handle can be moved
- True:  Handle can be clicked, used like a button

dir_vector: Optional[AllplanGeo.Vector3D] property writable

Get the direction vector of the handle point movement

distance_factor: float property writable

Get the factor for property calculation:

-1=show negative value in the input control. Multiply the distance between reference and handle point with the factor to get the property value, e.g. 2.0 if the ref_point is a center point.

ele_prop_list: List[Tuple[str, HandleDirection, bool, bool, bool, Any, Optional[Union[int, List[int]]]]] property

Get the parameter data as list of tuples

handle_angle: AllplanGeo.Angle property writable

Handle angle

:getter: Get the handle angle :setter: Set the handle angle

handle_id: Union[str, Tuple[int, str]] property

Get the handle id

handle_move_dir: HandleDirection property

Get the allowed move direction for the handle

handle_point: AllplanGeo.Point3D property writable

Get the handle point

handle_type: AllplanIFW.ElementHandleType property writable

Handle type

:getter: Get the handle type :setter: Set the handle type

info_text: str property writable

Info text of the tooltip

:getter: Get the info text of the tooltip :setter: Set the info text of the tooltip

parameter_data: List[HandleParameterData] property

Get tbe list with the parameter data of the handle

plane: Optional[AllplanGeo.Plane3D] property

Get the Input plane for the handle_point movement

ref_point: AllplanGeo.Point3D property

Get the reference point

show_handles: bool property writable

Get the show handles state

Functions

__init__(handle_id, handle_point, ref_point, handle_param_data, handle_move_dir, abs_value=True, distance_factor=1.0, plane=None, dir_vector=None, info_text='', angle_placement=None, show_handles=True)

Set the properties of a handle

Parameters:

Name Type Description Default
handle_id Union[str, Tuple[int, str]]

Unique handle ID, e.g. the name of the handle

required
handle_point Point3D

Handle point which will be moved

required
ref_point Point3D

Reference point for the distance calculation

required
handle_param_data List[HandleParameterData]

List with the parameter data. The parameter data are used for recalculation of the parameter property assigned to the handle. The calculation is performed depending on the defined parameter type.

required
handle_move_dir HandleDirection

Allowed move direction for the handle

required
abs_value bool

Use the absolute value from the calculation: True/False

True
distance_factor float

Factor for property calculation. -1=show negative value in the input control. Multiply the distance between reference and handle point with the factor to get the property value, e.g. 2.0 if the ref_point is a center point.

1.0
plane Optional[Plane3D]

Input plane for the handle_point movement

None
dir_vector Optional[Vector3D]

Direction vector for the handle point movement

None
info_text str

Information text of the tooltip

''
angle_placement Optional[AxisPlacement3D]

Placement for the 3D angle input

None
show_handles bool

Show handles state. This offers the possibility to use only the input by the edit fields

True

__repr__()

Create class information as string

transform(transformation_matrix)

Transform the handle

Parameters:

Name Type Description Default
trans_mat

transformation matrix

required