Skip to content

Outline Shape

Class full path: NemAll_Python_Precast.OutlineShape

Bases: IntEnum

outline shapes

Attributes

eBUILTIN_OUTLINE_SHAPE_NOTHING = 0 class-attribute instance-attribute

eBUILTIN_OUTLINE_SHAPE_RECTANGLE = 1 class-attribute instance-attribute

eBUILTIN_OUTLINE_SHAPE_SYMBOL = 3 class-attribute instance-attribute

eBUILTIN_OUTLINE_SHAPE_TRAPEZOID = 2 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
OutlineShape

value for the key