Skip to content

Functions of the module Reinforcement

Module full path: NemAll_Python_Reinforcement

Exposed classes and functions from NemAll_Python_Reinforcement

CreateReinforcementLabeling overload

CreateReinforcementLabeling(doc, insertionMat, labelList, viewProj, undoRedoService=None)

Create the reinforcement labels

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
insertionMat Matrix3D

Insertion matrix

required
modelEleList

List with the model elements

required
viewProj ViewWorldProjection

View projection

required
undoRedoService Optional[object]

Undo redo service

None
CreateReinforcementLabeling(doc, insertionMat, labelList, viewProj)

Create the reinforcement labels

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
insertionMat Matrix3D

Insertion matrix

required
labelList ReinforcementLabelList

List with the labels

required
viewProj ViewWorldProjection

View projection

required

InitApplicationtest()

InitUnitTest()