Skip to content

Bitmap Definition

Class full path: NemAll_Python_BasisElements.BitmapDefinition

Attributes

AbsolutePath: str property writable

RelativeName: str property writable

Functions

Create(bitmapName) staticmethod

Create a bitmap definition

Returns:

Type Description
BitmapDefinition

Bitmap definition

Parameters:

Name Type Description Default
bitmapName str

Path and name of the bitmap

required

Dump(deep)

Args: deep:

GetBitmapName()

GetHeight()

GetPixel(x, y)

Args: x: y:

GetWidth()

IsHDRI()

LoadBitmap()

setName(resourceName)

Args: resourceName: