Skip to content

Base Element Adapter List

Class full path: NemAll_Python_IFW_ElementAdapter.BaseElementAdapterList

Implementation of the base element adapter list

The BaseElementAdapterList is a general container for the BaseElementAdapter

Functions

__getitem__(index)

Get the item for the index

__iadd__(elements)

Add elements to the list

Parameters:

Name Type Description Default
elements BaseElementAdapterList

Elements.

required

__init__ overload

__init__()

Initialize

__init__(elements)

Constructor

Parameters:

Name Type Description Default
elements List[BaseElementAdapter]

Initializer list with the elements

required
__init__(eleList)

Copy constructor

Parameters:

Name Type Description Default
eleList BaseElementAdapterList

List to move

required

__iter__()

Get the iterator

__len__()

Get the length of the list

Returns:

Type Description
int

Length of the list

__repr__()

Get a string from the list items

append(element)

Append an element

Parameters:

Name Type Description Default
element BaseElementAdapter

Element to append

required

clear()

Clear the list