Skip to content

Section Along Path Properties

Class full path: NemAll_Python_BasisElements.SectionAlongPathProperties

Section along path properties

Attributes

ClippingPathProperties: SectionAlongPathClippingPathProperties property writable

Get the SectionAlongPathClippingPathProperties

FilterProperties: SectionAlongPathFilterProperties property writable

Get the SectionAlongPathFilterProperties

GeneralSectionProperties: SectionAlongPathGeneralSectionProperties property writable

Get the SectionAlongPathGeneralSectionProperties

ScaleProperties: SectionAlongPathScaleProperties property writable

Get the SectionAlongPathScaleProperties

Functions

__init__ overload

__init__(bInitFromSTW=False)

constructor

Parameters:

Name Type Description Default
bInitFromSTW bool
  • is structure initialized from standard values
False
__init__(B)

copy constructor

Parameters:

Name Type Description Default
B SectionAlongPathProperties
  • object to copy
required