Skip to content

Hook Length Service

Class full path: NemAll_Python_Reinforcement.HookLengthService

Service class for the hook length calculation

Functions

GetHookLength(hookAngle, hookType, diameter)

Calculate the hook length

Parameters:

Name Type Description Default
hookAngle float

Hook angle

required
hookType HookType

Hook type

required
diameter float

Diameter

required

Returns:

Type Description
float

Hook length

GetHookLengthPartFromBendingRoller(hookAngle, hookType, diameter)

Calculate the hook length part from the beginning of the bending roller

Parameters:

Name Type Description Default
hookAngle float

Hook angle

required
hookType HookType

Hook type

required
diameter float

Diameter

required

Returns:

Type Description
float

Hook length part from the beginning of the bending roller

GetHookLengthPartOfBendingRoller(hookAngle, hookType, diameter)

Calculate the hook length part of the bending roller

Parameters:

Name Type Description Default
hookAngle float

Hook angle

required
hookType HookType

Hook type

required
diameter float

Diameter

required

Returns:

Type Description
float

Hook length part of the bending roller

GetStandardAnchorageHookLength(diameter)

Calculate the standard anchorage hook length

Parameters:

Name Type Description Default
diameter float

Diameter

required

Returns:

Type Description
float

Standard anchorage hook length

__init__(norm, concreteGrade, steelGrade, bExactLength)

Constructor

Parameters:

Name Type Description Default
norm int

Norm

required
concreteGrade int

Concrete grade

required
steelGrade int

Steel grade

required
bExactLength bool

Calculate the exact length

required