Skip to content

Structural Brace Properties

Class full path: NemAll_Python_ArchElements.StructuralBraceProperties

Bases: StructuralElementProperties, ArchBaseProperties

Functions

GetEndPoint()

Get the end point of the element in world coordinate system

GetStartPoint()

Get the start point of the element in world coordinate system

SetAnchorPointProperties(val, point, val1, point1, bool)

Set the Brace Anchor Points Properties

Parameters:

Name Type Description Default
val int

Offset with Anchor Points Properties of Brace

required

SetEndPoint(x, y, z)

Set the end point of the element in world coordinate system

SetHeightProperties(doc, planeReferences)

Set HeightProperties

Parameters:

Name Type Description Default
PlaneReferences

Height Properties of Column, as PlaneReferences type

required

SetHeightPropsByPlacementPoints(doc, val, val1, val2)

Set HeightProperties

SetStartPoint(x, y, z)

Set the start point of the element in world coordinate system

__init__ overload

__init__()

Initialize

__init__(structuralBraceProps)

Copy constructor

Parameters:

Name Type Description Default
structuralBraceProps StructuralBraceProperties

Structural Brace properties

required