Skip to content

Section Along Path Text Parameter Properties

Class full path: NemAll_Python_BasisElements.SectionAlongPathTextParameterProperties

Text parameter properties

Attributes

BackgroundColorType: int property writable

Get the when =0 : no background color (transparency), when = 1 color is according to Allplan's view, when = 2, custom defined in CustomBackgroundColor

BorderColor: int property writable

Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

BorderLineType: int property writable

Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

BorderOffset: int property writable

Get the BorderOffset 0 it represents value -1; 4 repres. -0.5; 2 repres. 0.0; 1 repres.1.0; 5 repres. 2.0

BorderThickness: int property writable

Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

ColumnAngle: float property writable

Get the ColumnAngle

CustomBackgroundColor: int property writable

Get the when =0 : no background color (transparency), when = 1 color is according to Allplan's view, when = 2, custom defined in CustomBackgroundColor

FontAngle: float property writable

Get the FontAngle //ONLY for italic

FontColor: int property writable

Get the ColumnAngle

FontEmphasis: int property writable

Get the Font emphasis

FontHeight: float property writable

Get the FontHeight

FontID: int property writable

Get the FontType

FontLayer: int property writable

Get the ColumnAngle

FontThickness: int property writable

Get the pen of the text, never serialized, not in standard values, it is a working property only

FontWidth: float property writable

Get the FontWidth

IsFontColorFromLayer: bool property writable

Get the When False: it means scale dependent

IsFontLineTypeFromLayer: bool property writable

Get the When False: it means scale dependent

IsFontPenFromLayer: bool property writable

Get the When False: it means scale dependent

RowDistance: float property writable

Get the RowDistance //Line spacing

TextAngle: float property writable

Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

TextParameterID: TextPropertiesSource_Enum property writable

Initialize the class with Usable Values

TextParameterId: int property writable

Get the Text parameter ID

TextPlacementPointType: int property writable

Get the text placement point, see in NA_Data_TextDefines.h

UseBorderAroundTheText: bool property writable

Get the rotation of the text in radians, never serialized, not in standard values, it is a working property only

UseConstantSizeInLayout: bool property writable

Get the When False: it means scale dependent

Classes

TextEmphasis_Enum

Bases: IntEnum

enum for Section type

eUVS_ClippingPath : Clipping line with Allplan style symbols eUVS_AdvancedStyleClippingPath: Clipping line with advanced symbols(US Standard) eUVS_USStyleHeading : Heading for sections created with advanced symbols(US Standard) eUVS_USStyleScale : Scale for sections created with advanced symbols(US Standard)

eBold : according to N_FONTSTYLE_BOLD eItalic : according to N_FONTSTYLE_ITALIC eUnderline : according to N_FONTSTYLE_UNDERLINE eStrikethrough : according to N_FONTSTYLE_STRIKETHROUGH

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
TextEmphasis_Enum

value for the key

TextPropertiesSource_Enum

Bases: IntEnum

enum for Section type

eUVS_ClippingPath : Clipping line with Allplan style symbols eUVS_AdvancedStyleClippingPath: Clipping line with advanced symbols(US Standard) eUVS_USStyleHeading : Heading for sections created with advanced symbols(US Standard) eUVS_USStyleScale : Scale for sections created with advanced symbols(US Standard)

eBold : according to N_FONTSTYLE_BOLD eItalic : according to N_FONTSTYLE_ITALIC eUnderline : according to N_FONTSTYLE_UNDERLINE eStrikethrough : according to N_FONTSTYLE_STRIKETHROUGH

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
TextPropertiesSource_Enum

value for the key

Functions

DetectBackgroundColorType(bHasBgColor, bgColor, backgroundIsTransparent) staticmethod

Args: bHasBgColor: bgColor: backgroundIsTransparent:

FillPropertiesFromAllplanTextParameters(richTextFlags, layerId, byLayerFlags)

Args: richTextFlags: layerId: byLayerFlags:

__init__ overload

__init__()

Initialize

__init__(iTextParameterID, bInitFromSTW=False)

constructor

Parameters:

Name Type Description Default
iTextParameterID int
  • type of text parameter
required
bInitFromSTW bool
  • is structure initialized from standard values
False
__init__(bInitFromSTW)

constructor

Parameters:

Name Type Description Default
bInitFromSTW bool
  • is structure initialized from standard values
required
__init__(A)

copy constructor

Parameters:

Name Type Description Default
A SectionAlongPathTextParameterProperties
required