Skip to content

Cad Data File Reader

Class full path: NemAll_Python_BaseElements.CadDataFileReader

Functions

ReadIFC(doc, fileName) staticmethod

Import the data from an IFC file to be used as PythonPart content

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
fileName str

Name of the IFC file

required

Returns:

Type Description
list[tuple[str, list[ModelElement3D]]]

List with a tuple (group name, model elements)

ReadOBJ(fileName, designPathLocation) staticmethod

Import an OBJ file

Parameters:

Name Type Description Default
fileName str

Full file name of the OBJ file

required
designPathLocation eDesignPathLocation

Location of the design path

required

Returns:

Type Description
list[ModelElement3D]

List with the model elements

ReadSKP(fileName, designPathLocation) staticmethod

Import an SKP file

Parameters:

Name Type Description Default
fileName str

Full file name of the SKP file

required
designPathLocation eDesignPathLocation

Location of the design path

required

Returns:

Type Description
list[ModelElement3D]

List with the model elements