Skip to content

Attribute Integer Vec

Class full path: NemAll_Python_BaseElements.AttributeIntegerVec

Bases: Attribute

IntegerVec attribute

Attributes

Value: [list[int] | VecIntList] property writable

Get the attribute value

Functions

__eq__(element)

Equal operator

Parameters:

Name Type Description Default
element AttributeIntegerVec

Element to compare

required

Returns:

Type Description
bool

Elements are equal: true/false

__init__ overload

__init__()

Initialize

__init__(id, value)

Constructor

Parameters:

Name Type Description Default
id int

Attribute id

required
value [list[int] | VecIntList]

Attribute value

required
__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element AttributeIntegerVec

Element to copy

required

__ne__(element)

Unequal operator

Parameters:

Name Type Description Default
element AttributeIntegerVec

Element to compare

required

Returns:

Type Description
bool

Elements are unequal: true/false

__repr__()

Convert to string