Skip to content

e Polygon Normalize Type

Class full path: NemAll_Python_Geometry.ePolygonNormalizeType

Bases: IntEnum

type of Polygon2D normalization

Attributes

DEFAULT_NORM_TYPE = 0 class-attribute instance-attribute

HATCHING_MEASUR_NORM_TYPE = 2 class-attribute instance-attribute

HATCHING_NORM_TYPE = 3 class-attribute instance-attribute

SIDEFACE_NORM_TYPE = 1 class-attribute instance-attribute

STARTPOINT_NORM_TYPE = 4 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
ePolygonNormalizeType

value for the key