Skip to content

Reinforcement Settings

Class full path: NemAll_Python_Reinforcement.ReinforcementSettings

Functions

CheckBarDiameter() staticmethod

Check, whether the diameter is included in the diameter list of the current steel grade

Returns:

Type Description
float

Bar diameter (original or nearest value)

CheckMeshGroup() staticmethod

Check, whether the mesh group is included in the group list

Returns:

Type Description
int

Mesh group (original or first)

GetBarDiameter() staticmethod

Get the current bar diameter

Returns:

Type Description
float

Bar diameter

GetBarWeight(arg2) staticmethod

Get the weight for a bar diameter

Returns:

Type Description
float

Weight for a bar diameter

GetBendingRoller() staticmethod

Get the current bending roller

Returns:

Type Description
float

Bending roller

GetConcreteGrade() staticmethod

Get the current concrete grade

Returns:

Type Description
int

Concrete grade

GetMaxBarLength() staticmethod

Get the maximal bar length

Returns:

Type Description
float

Maximal bar length

GetMeshGroup() staticmethod

Get the current mesh group

Returns:

Type Description
int

Mesh group

GetMeshType() staticmethod

Get the current mesh type

GetNorm() staticmethod

Get the current norm

Returns:

Type Description
int

Norm

GetSteelGrade() staticmethod

Get the current steel grade

Returns:

Type Description
int

Steel grade

Is3DReinforcement() staticmethod

Get the 3D-Reinforcement state

Returns:

Type Description
bool

Create 3D-Reinforcement: true/false

__init__()

Initialize