e Layer Snoop Type
Class full path: NemAll_Python_IFW_Input.eLayerSnoopType
Bases: IntEnum
Definition of the layer snoop types
Attributes
eSnoopActiveLayers = 0
class-attribute
instance-attribute
eSnoopActiveLayersMsg = 3
class-attribute
instance-attribute
eSnoopAllLayers = 2
class-attribute
instance-attribute
eSnoopPassiveLayers = 1
class-attribute
instance-attribute
eSnoopPassiveLayersOrDocs = 4
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eLayerSnoopType
|
value for the key |