Skip to content

Plane Mesh Placement

Class full path: NemAll_Python_Reinforcement.PlaneMeshPlacement

Bases: ReinfElement, AllplanElement

Implementation of the mesh placement element

Attributes

CommonProperties: NemAll_Python_BaseElements.CommonProperties property writable

Get the common properties

MeshPolygon: NemAll_Python_Geometry.Polygon3D property writable

Get the shape polyline

PositionNumber: int property writable

Get the position number

Functions

GetCommonProperties()

Get the common properties

Returns:

Type Description
CommonProperties

Common properties

GetMeshData()

Get the mesh data

Returns:

Type Description
MeshData

Mesh data

GetMeshLength()

Get the mesh length

Returns:

Type Description
float

Mesh length

GetMeshPolygon()

Get the shape polyline

Returns:

Type Description
Polygon3D

Shape polyline

GetMeshWidth()

Get the mesh width

Returns:

Type Description
float

Mesh width

GetPositionNumber()

Get the position number

Returns:

Type Description
int

Position number

IsValid()

Get the state of the shape

Returns:

Type Description
bool

Shape is valid: true/false

Move(transVec)

Move the placement

Parameters:

Name Type Description Default
transVec Vector3D

Move vector

required

SetCommonProperties(commonProp)

Set the common properties

Parameters:

Name Type Description Default
commonProp CommonProperties

Common properties

required

SetMeshPolygon(shape)

Set the reinforcement shape

Parameters:

Name Type Description Default
shape Polygon3D

Reinforcement shape

required

SetPositionNumber(positionNumber)

Set the position number

Parameters:

Name Type Description Default
positionNumber int

Position number

required

Transform(transMat)

Transform the placement

Parameters:

Name Type Description Default
transMat Matrix3D

Transformation matrix

required

__init__ overload

__init__()

Initialize

__init__(placement)

Copy constructor

Parameters:

Name Type Description Default
placement PlaneMeshPlacement

Placement to copy

required
__init__(positionNumber, meshData, meshLength, meshWidth, meshPolygon)

Constructor

Parameters:

Name Type Description Default
positionNumber int

Position number

required
meshData MeshData

Mesh data

required
meshLength float

Mesh length

required
meshWidth float

Mesh width

required
meshPolygon Polygon3D

Mesh polygon

required

__repr__()

Convert to string