Skip to content

Axis Properties

Class full path: NemAll_Python_ArchElements.AxisProperties

Axis properties

Attributes

Distance: float property writable

Get the distance

Extension: int property writable

Get the extension

Modus: int property writable

Get the modus

OnLayer: int property writable

Get the axis layer

Position: int property writable

Get the axis position

Classes

WallAxisPosition

Bases: IntEnum

Position of the wall axis

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
WallAxisPosition

value for the key

Functions

__init__()

Initialize

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string