Element Adapter Type
Class full path: NemAll_Python_IFW_ElementAdapter.ElementAdapterType
Implementation of the element type
Attributes
IsVisible: bool
property
writable
Get the visible state of the element type
Functions
GetDisplayName()
Get the display name of the element
Returns:
Type | Description |
---|---|
str
|
Display name |
GetGuid()
Get the GUID
GetModelType()
Get the model type
GetTypeName()
Get the type name of the element
Returns:
Type | Description |
---|---|
str
|
Type name of the element |
GetZoomState()
Get the zoom state of the element type
Returns:
Type | Description |
---|---|
object
|
Zoom state |
Is3DElement()
Get the 3D element state
Returns:
Type | Description |
---|---|
bool
|
Element has 3D geometry: true/false |
IsInfoFromParent()
Get the element state for the element info
Returns:
Type | Description |
---|---|
bool
|
Use the element info from the parent element: true/false |
__eq__(guid)
Equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
guid
|
GUID
|
Type to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
Types are equal: true/false |
__ne__(guid)
Not equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
guid
|
GUID
|
Type to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
Types are equal: true/false |