Skip to content

Reinforcement Label Properties

Class full path: NemAll_Python_Reinforcement.ReinforcementLabelProperties

Attributes

ShowBarCount: None property

Set/get the show state for the bar count

:type: None

ShowBarDiameter: None property

Set/get the show state for the bar diameter

:type: None

ShowBarDistance: None property

Set/get the show state for the bar distance

:type: None

ShowBarLayer: None property

Set/get the show state for the bar layer

:type: None

ShowBarLength: None property

Set/get the show state for the bar length

:type: None

ShowBarPlace: None property

Set/get the show state for the bar place

:type: None

ShowBendingShape: None property

Set/get the show state for the bending shape

:type: None

ShowPositionAtEnd: None property

Set/get the show state for the bar diameter

:type: None

ShowPositionNumber: None property

Set/get the show state for the position number

:type: None

ShowSteelGrade: None property

Set/get the show state for the steel grade

:type: None

ShowTwoLineText: None property

Set/get the show state for the two line text

:type: None

Functions

__init__ overload

__init__()

Initialize

__init__(prop)

Copy constructor

Parameters:

Name Type Description Default
prop ReinforcementLabelProperties

Properties to copy

required

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string