Skip to content

Fixture Slide Element

Class full path: NemAll_Python_Precast.FixtureSlideElement

Bases: PrecastElement, AllplanElement

FixtureSlideElement class

Functions

GetFixtureSlideProperties()

Get the FixtureSlide properties

Returns:

Type Description
FixtureSlideProperties

FixtureSlide properties

GetObjectList()

Get the slide object list

Returns:

Type Description
list

Slide object list

SetFixtureSlideProperties(FixtureSlideProp)

Set the FixtureSlide properties

Parameters:

Name Type Description Default
FixtureSlideProp FixtureSlideProperties

FixtureSlide properties

required

__init__ overload

__init__()

Initialize

__init__(FixtureSlideProp, objectList)

Constructor

Parameters:

Name Type Description Default
FixtureSlideProp FixtureSlideProperties

FixtureSlide properties

required
objectList list

Object list of slide

required

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string