Skip to content

Bar Placement Section

Class full path: NemAll_Python_Reinforcement.BarPlacementSection

Implementation of the bar placement section class

Functions

GetDistance()

Get the distance

Returns:

Type Description
float

Distance

GetLength()

Get the length

Returns:

Type Description
float

Length

IsEnabled()

Get the enabled state

Returns:

Type Description
bool

Enable state

__init__ overload

__init__(isEnabled, length, distance)

Constructor

Parameters:

Name Type Description Default
isEnabled bool

Section enabled state

required
length float

Section length

required
distance float

Bar distance

required
__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element BarPlacementSection

Element to copy

required