Skip to content

Macro Type

Class full path: NemAll_Python_Precast.MacroType

Bases: IntEnum

types

Attributes

eGroup_Fixture = 3 class-attribute instance-attribute

eLine_Fixture = 1 class-attribute instance-attribute

ePlane_Fixture = 2 class-attribute instance-attribute

ePoint_Fixture = 0 class-attribute instance-attribute

eUseSameType = -1 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
MacroType

value for the key