Element Select Filter Setting
Class full path: NemAll_Python_IFW_Input.ElementSelectFilterSetting
Settings class to control the object selection
Attributes
LayerSelectType: eLayerSnoopType
property
writable
Get the layer selection type
Functions
Clear()
Reset the settings
GetLayerSelectType()
Get the layer selection type
IsBaseClassType(typeID)
staticmethod
Check, whether the element type is a base class type
Parameters:
Name | Type | Description | Default |
---|---|---|---|
typeID
|
GUID
|
Element type ID |
required |
IsClear()
Get the clear state
Returns:
Type | Description |
---|---|
bool
|
true, if the members contain default values |
IsPointSelect()
Get the point select state
Returns:
Type | Description |
---|---|
bool
|
Point selection is active: true/false |
IsSelectPassiveInfoElement()
Get the selection state of a passive info element
Returns:
Type | Description |
---|---|
bool
|
Allow to select passive info element if no active element was found: true/false |
SelectPassiveInfoElement()
Allow to select passive info element if no active element was found
SetArchitectureFilterQuery(positive=True)
Set a prefabricated filter for all architecture elements
Parameters:
Name | Type | Description | Default |
---|---|---|---|
positive
|
bool
|
if the filter will true for architecture elements otherwise the filter will be false for architecture elements |
True
|
SetAssoFilterQuery(positive=True)
Set a prefabricated filter for all associative view elements
Parameters:
Name | Type | Description | Default |
---|---|---|---|
positive
|
bool
|
if the filter will true for associative view elements otherwise the filter will be false for associative view elements |
True
|
SetDocumentLayerFilter(bSnoopAllElements)
Set the document and layer filter
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bSnoopAllElements
|
bool
|
Snoop all elements: true/false |
required |
SetDocumentSelectType(documentSnoopType)
Set the selection mode for the document (active, passive or all documents)
Parameters:
Name | Type | Description | Default |
---|---|---|---|
documentSnoopType
|
eDocumentSnoopType
|
Selection mode for the document (active, passive or all documents) |
required |
SetLayerSelectType(layerSnoopType)
Set the layer selection type
Parameters:
Name | Type | Description | Default |
---|---|---|---|
layerSnoopType
|
eLayerSnoopType
|
Type of the allowed layers for the selection |
required |
SetPointSelect()
Set the point select state
__init__
overload
__init__()
Initialize
__init__(bSnoopAllElements)
Constructor
default values: Query is empty
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bSnoopAllElements
|
bool
|
true = snoop all elements, false = snoop active elements |
required |
__init__(filter, bSnoopAllElements)
Constructor
default value for eObjectSelectType == SEL_ALL
Parameters:
Name | Type | Description | Default |
---|---|---|---|
filter
|
SelectionQuery
|
Filter for the type of the object to search for |
required |
bSnoopAllElements
|
bool
|
true = snoop all elements, false = snoop active elements |
required |
__init__(filter, documentSnoopType, layerSnoopType)
Constructor
default value for eObjectSelectType == SEL_ALL
Parameters:
Name | Type | Description | Default |
---|---|---|---|
filter
|
SelectionQuery
|
Filter for the type of the object to search for |
required |
documentSnoopType
|
eDocumentSnoopType
|
Selection mode for the document (active, passive or all documents) |
required |
layerSnoopType
|
eLayerSnoopType
|
Selection mode for the layer (active, passive or all layers) |
required |
__init__(selectSetting)
Copy Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
selectSetting
|
ElementSelectFilterSetting
|
Copy this ElementSelectFilterSetting |
required |