Skip to content

Mesh Area Placement Properties

Class full path: NemAll_Python_Reinforcement.MeshAreaPlacementProperties

Attributes

LapJointOffset: None property

Get/set the lap joint offset state

:type: None

MeshSizeRound: None property

Get/set the mesh size round state

:type: None

OverlapCross: None property

Get/set the cross overlap

:type: None

OverlapLongitudinal: None property

Get/set the longitudinal overlap

:type: None

PlacementDirection: None property

Get/set the placement direction

:type: None

PlacementEndJustified: None property

Get/set the placement end justified state

:type: None

PlacementStartChange: None property

Get/set the placement start change state

:type: None

StartLength: None property

Get/set the start length

:type: None

StartWidth: None property

Get/set the start width

:type: None

Classes

MeshPlacementDirection

Bases: IntEnum

Mesh placement direction

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
MeshPlacementDirection

value for the key

Functions

__init__()

Initialize

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string