Skip to content

Fixture Properties

Class full path: NemAll_Python_Precast.FixtureProperties

FixtureProperties class

Attributes

CatalogName: None property

Property for catalog name

:type: None

DomainType: None property

Property for domain type

:type: None

InsertionPoint: None property

Property for insertion point

:type: None

IsScaleDependent: None property

Property for scale dependent state

:type: None

Name: None property

Property for name

:type: None

PositionNr: None property

Property for position number

:type: None

SubType: None property

Property for sub type

:type: None

Type: None property

Property for type

:type: None

UnitFactor: None property

Property for unit factor

:type: None

Functions

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop FixtureProperties

FixtureProperties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__()

Initialize

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string