Skip to content

Value Input Control Data

Class full path: NemAll_Python_IFW_Input.ValueInputControlData

Functions

__init__ overload

__init__()

Initialize

__init__(ctrlType, bSetFocus, bDisableCoord)

Constructor to create a control with standard behavior defined by the control type

Parameters:

Name Type Description Default
ctrlType eValueInputControlType

Control type

required
bSetFocus bool

Set the input focus to the control: true/false

required
bDisableCoord bool

Input inside the external control disables the coordinate controls: true/false

required
__init__(ctrlType, initValue, bSetFocus, bDisableCoord)

Constructor to create a control with an init value.

The value range is defined by the control type

Parameters:

Name Type Description Default
ctrlType eValueInputControlType

Control type

required
initValue float

Initialize input value

required
bSetFocus bool

Set the input focus to the control: true/false

required
bDisableCoord bool

Input inside the external control disables the coordinate controls: true/false

required