Skip to content

Outline Type

Class full path: NemAll_Python_Precast.OutlineType

Bases: IntEnum

outline types

Attributes

eBUILTIN_OUTLINE_TYPE_MINUS = 2 class-attribute instance-attribute

eBUILTIN_OUTLINE_TYPE_NOTHING = 0 class-attribute instance-attribute

eBUILTIN_OUTLINE_TYPE_NO_AFFECT = 3 class-attribute instance-attribute

eBUILTIN_OUTLINE_TYPE_PLUS = 1 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
OutlineType

value for the key