Skip to content

Beam Properties

Class full path: NemAll_Python_ArchElements.BeamProperties

Bases: ArchBaseProperties

Implementation of the beam properties

Attributes

IsStartNewJoinedBeamGroup: bool property writable

Get the state for starting a new beam group

All beams in a group are used for to create a continues join between the beams.

Width: float property writable

Get the width

Functions

GetWidth()

Get the width

Returns:

Type Description
float

Width

SetAttribute(attrib)

Set the attribute

Parameters:

Name Type Description Default
attrib object

Attribute

required

SetAxis(axis)

Set the axis

Parameters:

Name Type Description Default
axis AxisProperties

Axis data

required

SetWidth(width)

Set the width

Parameters:

Name Type Description Default
width float

Width

required

__init__ overload

__init__()

Initialize

__init__(beamProp)

Copy constructor

Parameters:

Name Type Description Default
beamProp BeamProperties

Beam properties

required