Skip to content

Solid Element Truncation Type

Class full path: NemAll_Python_ArchElements.SolidElementTruncationType

Bases: IntEnum

Type of cutting/stretching

Attributes

FreePlane = 3 class-attribute instance-attribute

Horizontal = 1 class-attribute instance-attribute

NormalToBodyAxis = 0 class-attribute instance-attribute

Vertical = 2 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
SolidElementTruncationType

value for the key