Skip to content

Associative View Element

Class full path: NemAll_Python_BasisElements.AssociativeViewElement

Bases: AllplanElement

AssociativeViewElement class

Attributes

ClippingPathProperties: None property

Property for the clipping path properties

:type: None

DimensionElements: None property

Property for the dimension elements

:type: None

PlacementAngle: None property

Property for the placement angle

:type: None

PlacementPoint: None property

Property for the placement point

:type: None

ReinforcementLabels: None property

Property for the reinforcement labels

:type: None

SectionAngle: None property

Property for the section angle

:type: None

SectionPolyhedron: None property

Property for the section polyhedron

:type: None

TextElements: None property

Property for the text elements

:type: None

ViewMatrix: None property

Property for the view matrix

:type: None

ViewProperties: None property

Property for the view properties

:type: None

Functions

__init__()

Initialize

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string