Skip to content

Macro Placement Properties

Class full path: NemAll_Python_BasisElements.MacroPlacementProperties

Implementation of the macro placement element properties

Attributes

BillingCategory: int property writable

Get the Billing category

ConsiderType: ConsiderType property writable

Get the Consider type

Craft: int property writable

Get the Craft

DistortionState: bool property writable

Get the Distortion state

DomainType: int property writable

Get the Domain type?

HasParentModificationBehaviour: bool property writable

Get the Specific behavior for modification

HeightDefinitionType: NemAll_Python_Precast.HeightDefinitionType property writable

Get the Height definition type

InOpeningState: bool property writable

Get the Is the macro placement inside opening ?

LeadingMacro: bool property writable

Get the leading macro (post activation flag for connected elements - iseg1)

LinkType: LinkType property writable

Get the Link type

Mass_V6: float property writable

Get the Mass attribute V6

Mass_V7: float property writable

Get the Mass attribute V7

Mass_V8: float property writable

Get the Mass attribute V8

Mass_V9: float property writable

Get the Mass attribute V9

Matrix: NemAll_Python_Geometry.Matrix3D property writable

Get the Matrix for location in world coordinate system

MirrorState: bool property writable

Get the Was the macro placement mirrored ?

Name: str property writable

Get the Name

PositionNr: int property writable

Get the Unit factor

SubType: int property writable

Get the Subtype?

Type: int property writable

Get the Type?

UnitFactor: float property writable

Get the Unit factor

UseAlways2DRepInGroundView: bool property writable

Get the Use always 2D representation in ground view

UseDrawOrder: bool property writable

Get the Uses the draw order setting of the placement or the elements of the macro ?

UseFormat: bool property writable

Get the Uses the format setting (pen, stroke, color) of the placement or the elements of the macro ?

Functions

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop MacroPlacementProperties

MacroPlacementProperties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__ overload

__init__()

Initialize

__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element MacroPlacementProperties

Element to copy

required

__repr__()

Convert to string