Skip to content

Hook Type

Class full path: NemAll_Python_Reinforcement.HookType

Bases: IntEnum

Types of the hooks

Attributes

eAnchorage = 3 class-attribute instance-attribute

eAngle = 2 class-attribute instance-attribute

eStirrup = 1 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
HookType

value for the key