Skip to content

Element Node Element

Class full path: NemAll_Python_BasisElements.ElementNodeElement

Bases: BasisElement, AllplanElement

ElementNodeElement class

Functions

GetObjectList()

Get the list of element node objects

Returns:

Type Description
list

Element node object list

GetParentID()

Get parent ID

Returns:

Type Description
type

UUID

SetParentID(ParentID)

Set the parent element id to this object

Parameters:

Name Type Description Default
ParentID type

(UUID) sub element id

required

__init__ overload

__init__()

Initialize

__init__(commonProp, elementNodeId, elementNodeObjectList)

Constructor

Parameters:

Name Type Description Default
commonProp CommonProperties

Common properties

required
elementGroupProp

ElementGroup properties

required
elementGroupObjectList

ElementGroup object list

required

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string