Skip to content

Polygon2D List

Class full path: NemAll_Python_Geometry.Polygon2DList

List for Polygon2D objects

Functions

__contains__(value)

Check for a value in the list

Parameters:

Name Type Description Default
value Polygon2D

Value to check

required

Returns:

Type Description
bool

State for value is in the list

__delitem__(value)

Delete a list item

Parameters:

Name Type Description Default
value Polygon2D

Value to delete

required

__eq__(compare_list)

Compare two lists

__getitem__(index)

Get a list item

Parameters:

Name Type Description Default
index int

Index of the item

required

Returns:

Type Description
Polygon2D

Value for the index

__init__()

Initialize

__iter__()

List iterator

Returns:

Type Description
Iterator

List iterator

__len__()

Get the list length

Returns:

Type Description
int

Length of the list

__repr__()

Create a string from the elements of the list

__setitem__(index, value)

Set a list item

Parameters:

Name Type Description Default
index int | slice

Index of the item

required
value Polygon2D

Value to item

required

append(value)

Append a list item

Parameters:

Name Type Description Default
value Polygon2D

Value to append

required

extend(iterable)

Add the items from an iterable to the end of the list

Parameters:

Name Type Description Default
iterable Polygon2DList

Iterable to add

required