Skip to content

Hatching Properties

Class full path: NemAll_Python_BasisElements.HatchingProperties

Implementation of the hatching properties

Attributes

BackgroundColor: ARGB property writable

Get the background color

DirectionToReferenceLine: int property writable

Get the index of the direction line

ExistAlignment: bool property writable

Get the alignment state

HatchID: int property writable

Get the hatch ID

IsScaleDependent: bool property writable

Get the scale dependent state

ReferencePoint: NemAll_Python_Geometry.Point2D property writable

Get the reference point

RotationAngle: NemAll_Python_Geometry.Angle property writable

Get the rotation angle

UseBackgroundColor: bool property writable

Get the use background color state

UseReferencePoint: bool property writable

Get the use reference point state

Functions

SetBackgroundColorBGR(value)

Set the background color

Parameters:

Name Type Description Default
value int

Color value as BGR

required

SetBackgroundColorIRGB(value)

Set the background color

Parameters:

Name Type Description Default
value int

Color value as IRGB

required

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop HatchingProperties

HatchingProperties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__ overload

__init__()

Initialize

__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element HatchingProperties

Element to copy

required

__repr__()

Convert to string