Skip to content

Shading Type

Class full path: NemAll_Python_BasisElements.ShadingType

Bases: IntEnum

Shading types of the filling property

Attributes

eFromCenter = 2 class-attribute instance-attribute

eFromCorner = 1 class-attribute instance-attribute

eLinear = 0 class-attribute instance-attribute

eRound = 3 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
ShadingType

value for the key