Skip to content

Height Definition Type

Class full path: NemAll_Python_BasisElements.HeightDefinitionType

Bases: IntEnum

Height definition types

eNone : Height definition is not defined eMacro : Height definition macro eComponent: Height definition component eAverage : Height definition average

Attributes

eAverage = 3 class-attribute instance-attribute

eComponent = 2 class-attribute instance-attribute

eMacro = 1 class-attribute instance-attribute

eNone = 0 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
HeightDefinitionType

value for the key