Label Type
Class full path: NemAll_Python_Reinforcement.LabelType
Bases: IntEnum
Types of the label
Attributes
LabelWithComb = 2
class-attribute
instance-attribute
LabelWithComb2Pointer = 3
class-attribute
instance-attribute
LabelWithComb3Pointer = 4
class-attribute
instance-attribute
LabelWithDimensionLine = 1
class-attribute
instance-attribute
LabelWithFan = 5
class-attribute
instance-attribute
LabelWithFanStartCenterEnd = 7
class-attribute
instance-attribute
LabelWithFanStartEnd = 6
class-attribute
instance-attribute
LabelWithPointer = 0
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
LabelType
|
value for the key |