Skip to content

Handle Service

Class full path: NemAll_Python_IFW_Input.HandleService

Functions

AddHandles(doc, handlePropList, insertionMat, assoRefObj)

Add the handles

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
handlePropList object

Handle properties list

required
insertionMat Matrix3D

Transformation matrix

required
assoRefObj object

Reference element for the drawing inside the associative views

required

DeleteToolTipText()

Delete the tool tip text

DrawHandles()

Draw the handles

RemoveHandles()

Remove the handles

SelectHandle(pnt, viewProj)

Select a handle

Parameters:

Name Type Description Default
pnt Point2D

Cursor point

required
viewProj ViewWorldProjection

View world projection

required

Returns:

Type Description
tuple

Handle index (-1 = no selection) , world to associative view matrix

ShowToolTipText(text)

Show the tool tip text

Parameters:

Name Type Description Default
text str

Text

required

__init__()

Initialize