Skip to content

Arch Element Type

Class full path: NemAll_Python_IFW_ElementAdapter.ArchElementType

Bases: IntEnum

Attributes

tInvalid = 0 class-attribute instance-attribute

tSheet = 2 class-attribute instance-attribute

tSolid = 3 class-attribute instance-attribute

tWire = 1 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
ArchElementType

value for the key