Skip to content

Mesh Placement

Class full path: NemAll_Python_Reinforcement.MeshPlacement

Bases: ReinfElement, AllplanElement

Functions

GetBendingShape()

Get the shape polyline

Returns:

Type Description
BendingShape

Shape polyline

GetPositionNumber()

Get the position number

Returns:

Type Description
int

Position number

GetWidthVector()

Get the width vector

Returns:

Type Description
Vector3D

Width vector

Move(transVec)

Move the placement

Parameters:

Name Type Description Default
transVec Vector3D

Move vector

required

SetBendingShape(shape)

Set the reinforcement shape

Parameters:

Name Type Description Default
shape BendingShape

Reinforcement shape

required

SetPositionNumber(positionNumber)

Set the position number

Parameters:

Name Type Description Default
positionNumber int

Position number

required

SetWidthVector(widthVec)

Set the width vector

Parameters:

Name Type Description Default
widthVec Vector3D

Width vector

required

Transform(transMat)

Transform the placement

Parameters:

Name Type Description Default
transMat Matrix3D

Transformation matrix

required

__init__ overload

__init__()

Initialize

__init__(positionNumber, widthVec, bendingShape)

Constructor

Parameters:

Name Type Description Default
positionNumber int

Position number

required
widthVec Vector3D

Width vector of the mesh

required
bendingShape BendingShape

Mesh shape

required

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string