Skip to content

Bounding Box2D List

Class full path: NemAll_Python_Geometry.BoundingBox2DList

Functions

__contains__(value)

Check for a value in the list

Parameters:

Name Type Description Default
value BoundingBox2D

Value to check

required

Returns:

Type Description
bool

State for value is in the list

__delitem__(value)

Delete a list item

Parameters:

Name Type Description Default
value BoundingBox2D

Value to delete

required

__getitem__(index)

Get a list item

Parameters:

Name Type Description Default
index int

Index of the item

required

Returns:

Type Description
BoundingBox2D

Value for the index

__init__()

Initialize

__iter__()

List iterator

Returns:

Type Description
Iterator

List iterator

__len__()

Get the list length

Returns:

Type Description
int

Length of the list

__repr__()

Convert the list to a string

Returns:

Type Description
str

List values as string

__setitem__(index, value)

Set a list item

Parameters:

Name Type Description Default
index int | slice

Index of the item

required
value BoundingBox2D

Value to item

required

append(value)

Append a list item

Parameters:

Name Type Description Default
value BoundingBox2D

Value to append

required

extend(iterable)

Add the items from an iterable to the end of the list

Parameters:

Name Type Description Default
iterable BoundingBox2DList

Iterable to add

required