Skip to content

Python Parts Settings

Class full path: NemAll_Python_AllplanSettings.PythonPartsSettings

Implementation of the PythonParts settings

Attributes

IsShowFullPreview: bool property writable

Get the full preview state

Show the full preview

Functions

GetInstance() staticmethod

Get the instance

Returns:

Type Description
PythonPartsSettings

Instance of the singleton

SetLengthUnit(lengthUnit)

Set the length unit

Parameters:

Name Type Description Default
lengthUnit int

Length unit: 3 = m

required

SetShowFullPreview(showFullPreview)

Show the full preview

Parameters:

Name Type Description Default
showFullPreview bool

Show full preview: true/false

required