Skip to content

Library Element

Class full path: NemAll_Python_BasisElements.LibraryElement

Bases: BasisElement, AllplanElement

Implementation of the library element

Functions

GetCount()

Get the element count

Returns:

Type Description
int

Element count

GetGeometryElements(doc)

Get the geometry elements

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required

Returns:

Type Description
list

Geometry elements

GetMinMax(doc)

Get the min/max box of the element

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required

Returns:

Type Description
MinMax3D

Min/max box of the element

GetProperties()

Get the properties

Returns:

Type Description
LibraryElementProperties

Properties

GetReferencePoint(doc)

Get the reference point

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required

Returns:

Type Description
Point3D

Reference point

Move(moveVec)

Move the element

Parameters:

Name Type Description Default
moveVec Vector3D

Move vector

required

__init__ overload

__init__()

Initialize

__init__(libEleProp)

Constructor

Parameters:

Name Type Description Default
libEleProp LibraryElementProperties

Library element properties

required
__init__(libEle)

Copy constructor

Parameters:

Name Type Description Default
libEle LibraryElement

Library element to copy

required

__repr__()

Convert to string