Skip to content

Profil Type

Class full path: NemAll_Python_Precast.ProfilType

Bases: IntEnum

profil types

Attributes

eBUILTIN_PROFIL_TYPE_EDGE = 1 class-attribute instance-attribute

eBUILTIN_PROFIL_TYPE_JOINT = 0 class-attribute instance-attribute

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key str | int | float

value key

required

Returns:

Type Description
ProfilType

value for the key