Skip to content

Unit Service

Class full path: NemAll_Python_AllplanSettings.UnitService

Unit service

Functions

ConvertToMM(lengthString) staticmethod

Convert a value string to mm

Parameters:

Name Type Description Default
lengthString str

Length as string

required

Returns:

Type Description
tuple

Length in mm

ToLengthUnitString(length) staticmethod

Convert a length(mm) to a string by the current length unit

Parameters:

Name Type Description Default
length float

Length in mm

required

Returns:

Type Description
str

String with the value in the current length unit